EFF1 YM6007 Reverb Issue

The Yamaha SY99 is a synthesiser combining frequency modulation synthesis (branded as Advanced FM) and sample-based synthesis (branded as Advanced Wave Memory 2) and the direct successor to Yamaha's SY77/TG77

Moderators: Derek, parametric, Saul

User avatar
RCM
Posts: 3
Joined: Wed Jan 24, 2018 9:17 am
United States of America

EFF1 YM6007 Reverb Issue

Unread post by RCM » Wed Jan 24, 2018 9:36 am

The EFF1 (IC226) on my V1.57 PLCC version unit is sputtering unpleasant digital error noise any time notes are sent. Sounds like hideous 0dB early digital recording of firecrackers, unceasing once begun on some Algs. I haven’t had a working SY99 for very long, have just now sussed the effects.

The algorithms are probably arriving to the DSP chip and being executed properly from ROM, the problem is with the mangled audio signal going into EFF1. If you saw first version of this post, was confused about SY99 effects routing which meant different hypothesis, now updated.

This was determined this by flipping into the Dual Type Effects (from #52) on and listening to the difference in quality between Send1 and Send2 on a basic patch assigned to grp1. One signal is a little cleaner than the other. Nice to know I’m not about to have to source another DSP chip.

EFF2 still sounds great. The 1.10 internal test modes pass. I don't know how the YM6007 or associated buses actually work, if we knew how/where the DSP chip receives audio and what the dependencies are this problem could be diagnosed. Where’s the disconnect?

This actually started a few years ago when I was first attempting to increase from 1.4 to the final version. I didn't know at the time that XJ613H00 Requires XI722G00, when I applied power the LCD wouldn't come up without 1.5 CPU.

When I put the old firmware back in which corresponded to the original OTP CPU, my machine returned to normal except EFF1. I've thought until now that parameter initialization or a #49 fac reset would solve this but apparently not. Perhaps something was accidentally disrupted on DM2.

Both my IC226 and 227 have mint green selection markings in upper left indent. Has there ever been a situation where leakage from the nearby 2032 interfered with YM6007 lines 97-110?

Am deeply motivated to resolve this issue, have test gear, can possibly also reflow SMD. -Would be wonderful to restore the 99 glory, this instrument is sonically amazing and has tremendous experimental potential.
Attachments
180122-001430.jpg
User avatar
RCM
Posts: 3
Joined: Wed Jan 24, 2018 9:17 am
United States of America

Re: EFF1 YM6007 Reverb Issue

Unread post by RCM » Thu Jan 25, 2018 2:03 am

The serial and parallel data arrangements into the DSP chip are certainly interesting. Understanding all of the various clocking and latching is currently beyond me, however it would seem that a defective ESI (IC223) might explain some of the runaway feedback on certain Algs. It almost seems like the Send1, etc are the discrete signals for inputs SI0, SI1, SI2 of the DSP. Could any of the veteran SY99ers chime in on how often these various YM ASIC fail? How could I determine if the MIXOUT0 from IC225 is valid? Are there any serial or parallel effects combinations that could reveal more about this?
User avatar
Saul
Site Admin
Site Admin
Posts: 9303
Joined: Sun Feb 01, 2004 1:00 am
Contact:
Ireland

Re: EFF1 YM6007 Reverb Issue

Unread post by Saul » Thu Jan 25, 2018 2:37 am

Hi RCM. Just wanted to welcome you to yamahamusicians.com.

This stuff is way beyond me but I am sure we have some members who will understand and can contribute soon.
Saul
Site Admin
Review Yamahamusicians.com on Trustpilot
Sign up to the Newsletter
Follow us on Twitter @YamahaMusicians
Follow Us On Facebook
Dowina Cabernet DC/Dowina Chardonnay GAC DS/Dowina Rustica GAC/Seagull S6 Original/Harley Benton CLA-15MCE/Ashbury AG-160/Roland FA-07/Pianoteq 6 Pro/Amplitube 3.0/Apple iMac 27"/GarageBand 10.0.3/Logic Pro X/Cubase AI 9/Absynth 5/Ableton Live 9/KRK Rokit RP5 G3 Monitors
Website Design & Managed Hosting - Earn 35% Commission On Referrals! www.rabbittree.uk
User avatar
RCM
Posts: 3
Joined: Wed Jan 24, 2018 9:17 am
United States of America

Re: EFF1 YM6007 Reverb Issue

Unread post by RCM » Thu Jan 25, 2018 4:19 am

Ahoy Saul! Thanks for welcoming! Am here to make contributions as well as pursue advise. Although outputs from AFM and AWM ASICs arriving finally at IC225 might have been designed around manufac cost, the moment someone thought to plug an AWM stream into the OPerators something valuable and incredible was born, though Kurzweil VAST can circumvent IP to approximate RCM, it is tonally inferior due to topology. Why RCM (1991 SY99), FDSP (1998 EX5) and FSEQ (1998 FS1r) aren't present in the Montage product remains a mystery to me
Attachments
H8.jpg
Post Reply

Return to “Yamaha SY99 Forum”