RE: Roland DEP-5 (poss. faults?)

All Roland Keyboard and equipment that doesn't have a dedicated section

Moderators: Derek, parametric, Saul

User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Wed Aug 08, 2018 3:49 pm

Hi folks,

I have borrowed a Roland Digital Effects Processor ('DEP-5') from a friend today. I wanted to try it out as he may be selling it:

http://www.polynominal.com/roland-dep5/index.html

However, when I select a patch, the parameters in the display LED jump and change of their own accord!; please see video:

https://drive.google.com/open?id=1DYtU6 ... jPWjyZfkSZ

Any ideas, please?

Many thanks in advance ...

Paul
Fender Rhodes Suitcase / Fender Rhodes Stage / MiniMoog Model D / MultiMoog / Hohner E7 Clavinet / Yamaha DX7 (Mk1), DX21 & DX27 / Roland Juno 6 / Korg Poly_61.

Mackie SRM 350 (pair), Fender DeVille, Yamaha HS7 (pair), BeyerDynamic DT880 Headphones (250 Ohm).

Cubase 9.5 / Sibelius 8.5

Dell Inspiron N5040, Windows 10 Home, 16GB RAM, 64-bit, 2.13gHz, Service Pack 1.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1738
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by Miks » Wed Aug 08, 2018 9:13 pm

Hi Paul,

the DEP-5 has an internal battery (CR2032 - 3Volt) - maybe the battery has reached its life end? Thing is, the only way to 'measure' the voltage is to open up the unit and use a meter... 8O
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Wed Aug 08, 2018 9:30 pm

Miks wrote:
Wed Aug 08, 2018 9:13 pm
the DEP-5 has an internal battery (CR2032 - 3Volt) - maybe the battery has reached its life end? Thing is, the only way to 'measure' the voltage is to open up the unit and use a meter... 8O
Miks,

Is, what's appearing in my video, typical symptoms of a dying battery, please?

I was wondering, if like on the Yamaha DX7, there was a Battery-Checker reading?

My friend said the battery needs changing every 5 years, apparently. Also, he has not powered the unit up for a substantial period of time.

Ta,

Paul
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Wed Aug 08, 2018 9:31 pm

We almost look like NEGATIVES of each other in our avatars! lol
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1738
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by Miks » Wed Aug 08, 2018 10:00 pm

monsterjazzlicks wrote:
Wed Aug 08, 2018 9:30 pm
Is, what's appearing in my video, typical symptoms of a dying battery, please?
The symptoms of dying batteries/accumulators of an electronical device could cause lots of unexpected behaviour which often cannot been foreseen and may be very different from unit to unit. 8O
I was wondering, if like on the Yamaha DX7, there was a Battery-Checker reading?
After a quick look into the service notes I dare saying: NO
My friend said the battery needs changing every 5 years, apparently. Also, he has not powered the unit up for a substantial period of time.
Maybe the psu fails - but to be sure you have to measure the voltage(s) of the power rails and check for the correct values...
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Wed Aug 08, 2018 10:32 pm

Miks,

It has a built-in mains-lead; so no detachable power-supply/adapter.

Ta.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1738
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by Miks » Thu Aug 09, 2018 12:08 am

monsterjazzlicks wrote:
Wed Aug 08, 2018 10:32 pm
Miks, it has a built-in mains-lead; so no detachable power-supply/adapter.
Jepp - I know from the service notes. To check and see if the rails 'are good' it needs a tech-savvy person... 8O
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Thu Aug 09, 2018 11:36 pm

Hi Miks,

The batteries on eBay look too hit and miss. Too many from China and with neg. feedback!

Do you these are correct, on Amazon, please?:

https://www.amazon.co.uk/Duracell-Speci ... ts+battery

Ta,

Paul
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1738
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by Miks » Fri Aug 10, 2018 12:41 am

monsterjazzlicks wrote:
Thu Aug 09, 2018 11:36 pm
Hi Miks, the batteries on eBay look too hit and miss. Too many from China and with neg. feedback!

Do you these are correct, on Amazon, please?:

https://www.amazon.co.uk/Duracell-Speci ... ts+battery
I don't think so - on Polynominal.com they state that the DEP-5 has its battery soldered onto the mainboard 8O

http://www.polynominal.com/roland-dep5/index.html

Scroll down to (about) the middle of the site...

I haven't found a proper picture yet of that mainboard showing the details... :?

Here's a vid about a DEP-5 repair...
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Fri Aug 10, 2018 2:37 pm

Thanks for the LINK Miks.

Wow, that's such a long video!

Ta,

Paul
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1738
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by Miks » Fri Aug 10, 2018 3:01 pm

monsterjazzlicks wrote:
Fri Aug 10, 2018 2:37 pm
Wow, that's such a long video!
Jepp - but the most interesting 'part' starts about 32:20 when he starts to find out that in this case a dry solder joint is causing the issue... 8)
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Fri Aug 10, 2018 4:11 pm

Gee, I will have to fast forward it on! ...
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Sun Aug 12, 2018 8:09 pm

Hi Miks,

I have just sent all of your kind info to my electrician friend.

Ta.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1738
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by Miks » Sun Aug 12, 2018 8:51 pm

I'll keep my fingers crossed that those informations provided may help to resurrect the DEP-5 8)
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
monsterjazzlicks
Super Patch Creator
Super Patch Creator
Posts: 1661
Joined: Wed Mar 13, 2013 7:37 pm
Great Britain

Re: RE: Roland DEP-5 (poss. faults?)

Unread post by monsterjazzlicks » Sun Aug 12, 2018 8:55 pm

Miks wrote:
Sun Aug 12, 2018 8:51 pm
I'll keep my fingers crossed that those informations provided may help to resurrect the DEP-5 8)
I included your LINKS and also I d/l and attached the service manual. It may be worth the gamble of paying 20GBP just to get the unit diagnosed. When its working, it's a lovely piece of kit!
Post Reply

Return to “Roland”