Yamaha DX7 II-D power "restart" problem

This section is for all variants of the Yamaha DX series. DX1/DX100/DX11/DX21/DX27/DX27S/DX5/ DX7/DX7IID/DX7IIFD/DX7S/DX9/TX81Z/TX7

Moderators: Derek, parametric, Saul

User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Wed Nov 28, 2018 10:59 am

Hey guys! I inherited a DX7 II-D from my uncle recently and everything seemed fine. After few days when I played the instrument, after 5-8 minutes it "restarted" (like very quick off-on). I think there has to be a problem with power but I tried to plug it into overvoltage protection plug but the problem remains. I tested it battery level says 30v and my uncle told me he changed it in 2017.
I'm afraid that there is problem with power supply and no one ships new power supplys anymore. There is a licenced service center in my country (Czech Republic) but I'm afraid it will cost a fortune.
Does anyone know what could be a problem?
Thanks for your reply.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Wed Nov 28, 2018 12:41 pm

Hi nuttelaboi,

welcome to the forum! (Y) :D

Please see here & please read the entire thread - it may be helpful to solve that issue... 8)

viewtopic.php?f=35&t=11766

regards,
Miks
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Wed Nov 28, 2018 1:15 pm

Miks wrote:
Wed Nov 28, 2018 12:41 pm
Hi nuttelaboi,

welcome to the forum! (Y) :D

Please see here & please read the entire thread - it may be helpful to solve that issue... 8)

viewtopic.php?f=35&t=11766

regards,
Miks

Hi Miks, thank you for the welcome!

I think that this thread is somehow related, but my DX7 iid works perfectly, i don't think that 'won't power on' is similar problem. I hope someone know something. It is a minor issue imo.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Wed Nov 28, 2018 3:06 pm

Now - the fact that the synth is working for about 5-8 minutes makes me think of a temperature related issue. And some failing electrolytic capacitors tend to react on temperature changings. Try to use a hot air gun and carefully warm up the electrolytic capacitors one by one and see how the synth reacts. Otherwise you can use some cooling/freezing spray (if at hand) to 'search in the other direction' - IYSWIM... 0-)
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Wed Nov 28, 2018 4:20 pm

Miks wrote:
Wed Nov 28, 2018 3:06 pm
Now - the fact that the synth is working for about 5-8 minutes makes me think of a temperature related issue. And some failing electrolytic capacitors tend to react on temperature changings. Try to use a hot air gun and carefully warm up the electrolytic capacitors one by one and see how the synth reacts. Otherwise you can use some cooling/freezing spray (if at hand) to 'search in the other direction' - IYSWIM... 0-)
I have a meeting with synth specialist (and repairman) scheduled on tomorrow, so we'll see, maybe you were right. He wrote me (by email) that it can be a simple PSU malfunciton, so he can repair it really quickly and cheaply BUT it can also be a CPU malfunction (that I hope it isn't!), because prices of CPUs for DX7 II-D is in price range of another DX7.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Wed Nov 28, 2018 4:26 pm

I think it's a glitch caused by a malfunctioning power supply - but you may prove me wrong :)

I'll keep my fingers crossed that you may quickly find & fix that issue - and please report your findings here... :wink:

Oh - and let me know if you need the schematic for the DX7IID/FD - I have a corrected version which I can send you (there's one diode (D8) missing within the power supply schematic part!).
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Wed Nov 28, 2018 4:30 pm

Miks wrote:
Wed Nov 28, 2018 4:26 pm
I think it's a glitch caused by a malfunctioning power supply - but you may prove me wrong :)

I'll keep my fingers crossed that you may quickly find & fix that issue - and please report your findings here... :wink:
Thank you Miks. When I'll receive new information I post it here. :-) That guy has really good reputation across many czech synth forums so I'll see. (Y) :-)
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Fri Nov 30, 2018 12:24 pm

Miks wrote:
Wed Nov 28, 2018 4:26 pm
I think it's a glitch caused by a malfunctioning power supply - but you may prove me wrong :)

I'll keep my fingers crossed that you may quickly find & fix that issue - and please report your findings here... :wink:

Oh - and let me know if you need the schematic for the DX7IID/FD - I have a corrected version which I can send you (there's one diode (D8) missing within the power supply schematic part!).
So the "doctor" said, that this error is almost untraceable, because it occurs once/twice per a period of time, told me that he'll diagnose the instrument. He opened my DX and discovered that the malfunction was (maybe) caused by battery that was changed wrongly (in 2017). It hung on wires and when I played, it had to touch the motherboard so MB detected it and restarted the piano. He soldered the battery to the MB and I hope, he solved this problem.
Advise for everyone - change the battery properly! It can do this kind of harm.
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Fri Nov 30, 2018 1:54 pm

Oh - what an outcome! Then your uncle did the battery swap in a 'not so professional way' 8O

But now the issue seems to be fixed so I'll cross my fingers that your DX will work flawlessly from now on 0-)

And thanks for reporting back... (Y)
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Thu Dec 06, 2018 1:32 pm

Miks wrote:
Fri Nov 30, 2018 1:54 pm
Oh - what an outcome! Then your uncle did the battery swap in a 'not so professional way' 8O

But now the issue seems to be fixed so I'll cross my fingers that your DX will work flawlessly from now on 0-)

And thanks for reporting back... (Y)
Hey Miks, so here is a picture of that malfunctioning battery, everyone shouldn't replace it like that -
Battery fail.jpg
Battery fail.jpg (48.38 KiB) Viewed 91 times
Thank you for your replys, I hope this can help someone in the future :-)
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Thu Dec 06, 2018 1:56 pm

Yikes! :!: :shock: Nobody should do it like this :!:
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Thu Dec 06, 2018 10:23 pm

So today I picked my DX7 II from the repairman. I tested by EDIT1632 the new battery and it says 32v, so it's replaced. Pic of old battery is above. It seemed, problem is gone but when I played the instrument for second time (after an hour), the problem is back! It's a terrible situation and I dunno what's wrong. He diagnosed the instrument, everything seems good, I guess I have to live with that until something in it blows up and then he'll know, certainly, what is wrong. My another tip is that i have some corrupted data in performance mode. Maybe when I put a new *.syx files it'll be gone, but it's a "blind shot", i'm completely lost. :(
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Thu Dec 06, 2018 11:08 pm

Oh - sad to hear you still have trouble with your synth... :think: Does it only occur when in Performance mode and maybe using a certain 'repository'? Let's say for example: if you choose Performance Nr. # 17 the synth restarts, all other Performance Nr's work ok? Does the synth behave 'normal as it should' when not in Performance mode?
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
User avatar
nuttelaboi
Member
Member
Posts: 10
Joined: Wed Nov 28, 2018 10:45 am
Czech Republic

Re: Yamaha DX7 II-D power "restart" problem

Unread post by nuttelaboi » Fri Dec 07, 2018 11:46 am

Miks wrote:
Thu Dec 06, 2018 11:08 pm
Oh - sad to hear you still have trouble with your synth... :think: Does it only occur when in Performance mode and maybe using a certain 'repository'? Let's say for example: if you choose Performance Nr. # 17 the synth restarts, all other Performance Nr's work ok? Does the synth behave 'normal as it should' when not in Performance mode?
I think synth does what it wants to do. Sometimes it occurs, sometimes it does not. I think, after battery replacement, it got better. It happens when synth is in PF mode and even when it isn't. I'll try to put new *.syx files to DX7 and see, what'll happen. :)
User avatar
Miks
Specialist Moderator
Specialist Moderator
Posts: 1732
Joined: Fri Oct 31, 2008 1:00 am
Germany

Re: Yamaha DX7 II-D power "restart" problem

Unread post by Miks » Fri Dec 07, 2018 12:09 pm

nuttelaboi wrote:
Fri Dec 07, 2018 11:46 am
I'll try to put new *.syx files to DX7 and see, what'll happen. :)
Yes, good idea. But on the other hand - I (personally) have never heard or experienced that a 'broken' syx-file can cause such an issue like this sporadic reset of a DX7... :think:
My (key related) gear (in alphabetical order):
Ferrofish: B4000+
Kawai: K1 II
Korg: M1 (up'd to EX, w/ 'Cool Blue'), M1REX (w/ 'Cool Blue'), Poly-800
Roland: D-50, D-110, D-550, PG-1000
Yamaha: AW1600, DX7IID (w/ 'Cool Blue'), EX5R, RM50, RX5, SY99 (w/ 'Cool Blue'), TG500, TX-802, YMM2
Sector101: SYEMB05 (5x), SYEMB06 (3x), EXFLM2 (1kit), MCD Sweet16 (1x), WaveBlade 8MB Card (1x) & 1x Programmer Unit for WaveBlade
Post Reply

Return to “Yamaha DX & TX Forum”