CVP 309GP LCD problem

Moderators: Derek, parametric, Saul

User avatar
PeteThePilot
Posts: 1
Joined: Mon Mar 08, 2021 9:35 am
3
Where Are You Located?: United Kingdom

CVP 309GP LCD problem

Unread post by PeteThePilot »

Hello,

For a long time now, the LCD on my CVP-309GP has had lines down part of the screen. Having a lot of time on my hands at the moment, I decided to investigate.

On start up I get this:
JPEG image 5.jpeg
During warm up, this:
JPEG image 3.jpeg
Briefly, the full (and correct) image builds but quickly reverts to (and remains) like this:
JPEG image 4.jpeg
I found a service manual online and dismantled the piano body. The ribbon cable feeding the screen was slightly damaged, so it seemed to be the place to start. After three attempts I managed to get the correct cable from China. However, the display does exactly the same thing.

I entered the test program function and carried out test no. 37 - LCD Pattern check, producing the following results:
RGB pattern:
IMG_7922.jpg
Rainbow pattern:
IMG_7923.jpg
Flicker noise check pattern:
IMG_7924.jpg
They would indicate that the screen itself is OK (with maybe a question mark about some lines on the rainbow pattern) which makes me reluctant to buy a replacement screen (unless someone can advise differently).

I've gone as far as I can with my troubleshooting. Any ideas how to proceed please?

Thanks

Pete
User avatar
SK-2000 England
Posts: 1
Joined: Tue Jul 09, 2024 1:51 pm
Where Are You Located?: UK

Re: CVP 309GP LCD problem

Unread post by SK-2000 »

Hi Pete. I also have the same piano. Did you manage to resolve this issue and if you did any chance of assisting how you managed to do it as I have the same problem. Also where did you get a service manual from. Hope you can help.
Thanks
Post Reply